Error a l'intentar instalar timeoverflow en local

#1

Hola Sergi,

és que no tinc el teu email, si me’l passes ja et tindré fitxat.

Estava intentant instalar en local timeoverflow i m’'ha fallat al fer

 bundle install --path vendor/bundle

Bundler could not find compatible versions for gem “bundler”:
In Gemfile:
rails (~> 4.2) was resolved to 4.2.11.1, which depends on
bundler (>= 1.3.0, < 2.0)

i més coses que diu…

Pinta a ser un tema de versions del ruby, però com no en tinc ni idea de desenvolupament amb ruby i segur que us hi heu trobat, podriem buscar un moment i intentem resoldre-ho.

Merci!

#2

Hola @zarpilla, estas fent servir aquesta guia?

#3

Sí, estic fent servir la guia aquesta.

De fet vaig tenir un error previ degut a que la versió del ruby que es va instalar era la 3.0.1 (de memòria ho dic) i al gemfile demanava la 3.0.0. Buscant a stackoverflow, deien de fer un

bundle update

Va marxar aquell error i va apareixer aquest.

#4

Clar, bundle update et modifica el Gemfile.lock i trenca varies coses. Hauries de tornar al primer error :sweat_smile:

EDIT: per cert, la versio’ de Ruby que installem es la 2.3.0, ho pots veure aqui. La versio’ de Ruby que fem servir a la app es la mateixa, ho pots verificar aqui.

#5

Hola @enricostn, @sseerrggii

Amb la sentència:

 ansible-playbook playbooks/provision.yml --limit=dev

Obtinc l’error:

TASK [common : Symlink chromedriver globally] **********************************
fatal: [local.timeoverflow.org]: FAILED! => {"changed": false, "gid": 0, "group": "root", "mode": "0755", "msg": "refusing to convert from file to symlink for /usr/bin/chromedriver", "owner": "root", "path": "/usr/bin/chromedriver", "size": 12375944, "state": "file", "uid": 0}

Si tot i l’error, continuo, arribo al següent

timeoverflow@timeoverflow:/var/www/timeoverflow$  bundle install --path vendor/bundle
Fetching gem metadata from https://rubygems.org/...........
Fetching gem metadata from https://rubygems.org/..
Resolving dependencies....
Bundler could not find compatible versions for gem "bundler":
  In Gemfile:
    rails (~> 4.2) was resolved to 4.2.11.1, which depends on
      bundler (< 2.0, >= 1.3.0)

  Current Bundler version:
    bundler (2.0.1)
This Gemfile requires a different version of Bundler.
Perhaps you need to update Bundler by running `gem install bundler`?

Could not find gem 'bundler (< 2.0, >= 1.3.0)', which is required by gem 'rails
(~> 4.2)', in any of the sources.

Bundler could not find compatible versions for gem "rufus-scheduler":
  In Gemfile:
    rufus-scheduler (~> 3.4.2)

    sidekiq-cron (= 0.6.3) was resolved to 0.6.3, which depends on
      rufus-scheduler (>= 3.3.0)

Bundler could not find compatible versions for gem "sidekiq":
  In Gemfile:
    sidekiq (= 5.1.3)

    sidekiq-cron (= 0.6.3) was resolved to 0.6.3, which depends on
      sidekiq (>= 4.2.1)

I ja no se com continuar. A veure si em podeu donar un cop de ma :pray::pray:

#6

Si, tenemos una issue abierta para solucionar ese problema:

Creo que si cambias latest por 1.17.0 en la linea https://github.com/coopdevs/timeoverflow-provisioning/blob/master/roles/common/tasks/ruby.yml#L5 deberias poder seguir.

A ver si alguien se anima a arreglar ese problema :sweat_smile:

#7

Hola @enricostn,

Continuo con el mismo error después de cambiar la versión por el 1.17.0 :sleepy:

hizo este tema público #8
#9

Hola @enricostn, @sseerrggii,

Vaig avançant, però encara no ho tinc… He tornar a començar tot, destruint el lxc-container, eliminant la dependència amb chomedriver i ha acabat bé la instalació del provision.yml però al final un altre cop el mateix error al bundle install

Bundler could not find compatible versions for gem "bundler":
  In Gemfile:
    rails (~> 4.2) was resolved to 4.2.11.1, which depends on
      bundler (< 2.0, >= 1.3.0)

  Current Bundler version:
    bundler (2.0.1)
This Gemfile requires a different version of Bundler.

He fet lo següent:

gem uninstall bundler -v ">= 2.0" 
gem install bundler -v "< 2.0" 

bundle install --path vendor/bundle

i he pogut continuar fins un nou error:

Installing sassc 2.0.1 with native extensions
Gem::InstallError: sassc requires Ruby version >= 2.3.3.
An error occurred while installing sassc (2.0.1), and Bundler
cannot continue.
Make sure that `gem install sassc -v '2.0.1' --source 'https://rubygems.org/'`
succeeds before bundling.

In Gemfile:
  bootstrap-sass was resolved to 3.4.1, which depends on
    sassc

Investigo a partir d’aquí.

Salut!

#10

Vaig documentant.

He afegit la seguent linea al Gemfile

gem 'sassc', git: 'https://github.com/DeeDeeG/sassc-ruby', ref: '19f07dfc2790173f8a73fe0bfa1310fcdbbd63ce'

segons el que es suggeria a https://github.com/twbs/bootstrap-sass/issues/1182#issuecomment-463486260

i ha avançat fins a un nou error:

Installing capybara 3.19.1
Gem::InstallError: capybara requires Ruby version >= 2.4.0.
An error occurred while installing capybara (3.19.1), and Bundler
cannot continue.
Make sure that `gem install capybara -v '3.19.1' --source
'https://rubygems.org/'` succeeds before bundling.

He modificat la linea

  gem 'capybara', '~> 3.13'

per

  gem 'capybara', '3.13'

i tatxan!!!

Bundle complete! 52 Gemfile dependencies, 163 gems now installed.
Bundled gems are installed into `./vendor/bundle`
#11

Cal dir que quan ja estava emocionat, ha petat després del login:

#12

Molt bona estrategia, jo la faig servir sovint. :muscle:

:sweat_smile: vas executar bundle exec rake db:setup abans de aixecar el servidor?

Merci pel feedback i sorry pels problemes… el software esta’ viu i es trenca quan menys t’ho esperes :smile:

#13

Sí,
vaig executar abans bundle exec rake db:setup
Per continuar, he hagut de comentar la linea elseif accepted < ... i així he pogut arrencar. Però amb aquesta línea, no xuta.

Merci!